Circles not working on CNC

Here is a place we can talk about using ZTW CNC platform for 3D printing. Your experience with software setup, configuration for different type of filament and etc.

Circles not working on CNC

Postby Stoffel21 » Wed Sep 24, 2014 10:57 pm

Hello everyone.

I've assembled and configured my Zen CNC machine and I'm running into an issue when trying to CNC a simple cirlce.

I created a profile of a circle using MakerCam, and sent the Gcode to Grbl Controller 3.5. Below is a visualization of the G-code that i am trying to send.

The problem is when I run the job, look how jaggedy my "circle" comes out. Why is this the case? Are there some settings I need to send to the Arduino? Do you have a useful list of settings/documentation that I can send to the Arduino?

Here are my current Grbl settings:

$0=200
$1=200
$2=200
$3=10
$4=500.000
$5=500.000
$6=0
$7=50
$8=25.000
$9=0.050
$10=0.100
$11=25
$12=3
$13=0
$14=1
$15=0
$16=1
$17=1
$18=0
$19=25.000
$20=250.000
$21=100
$22=1.000
Attachments
cnc2.png
cnc1.png
User avatar
Stoffel21
New User
 
Posts: 3
Joined: Wed Sep 24, 2014 3:11 am
Zen Model: Zen 0712 (Ext. Mod)

Re: Circles not working on CNC

Postby johntech » Thu Sep 25, 2014 9:31 am

I am not familiar with that software as I use Mach 3 but it seems it might be one of your software settings. Maybe something to do with the step size?
Just guessing here....Sorry

John
User avatar
johntech
Forum Moderator
 
Posts: 422
Joined: Tue Mar 22, 2011 7:09 pm
Zen Model: Zen 1212

Re: Circles not working on CNC

Postby Stoffel21 » Thu Sep 25, 2014 2:02 pm

Thanks for the reply, John.

When I send $10=0.100 to Grbl Controller I think that's what determines the step size and sets it to each step being 1/10th of a millimeter which definitely seems like a small enough step size.

Hmm I'm stumped and I'm not sure what to check next. I tried sending a square profile to grbl controller and that worked just fine...
User avatar
Stoffel21
New User
 
Posts: 3
Joined: Wed Sep 24, 2014 3:11 am
Zen Model: Zen 0712 (Ext. Mod)

Re: Circles not working on CNC

Postby Stoffel21 » Fri Sep 26, 2014 12:24 am

Yes! I got the circles to cut without being jagged!

The problem is that the lines of gcode created by Makercam saves too many decimal places in the code for Grbl to handle.

I fixed the issue by truncating the gcode to have only 2 decimal places (instead of like 18) and then the circle code ran successfully.

Now the next issue I have to deal with is that the parts are coming out much bigger than they should. For example, a 5cm circle is being cnc'd at about 7 cm. Looks as if there's a consistent pattern of everything being 20% larger than it should be...
User avatar
Stoffel21
New User
 
Posts: 3
Joined: Wed Sep 24, 2014 3:11 am
Zen Model: Zen 0712 (Ext. Mod)


Return to 3D Printing with ZTW Filament and CNC

cron

x